Just Another Blog

Are you thinking what I'm thinking?

Wednesday, August 18, 2004

Mummy 7.2

Netscape 7.2 is out (though not recommended! Use Mozilla/Firefox instead...). It is roughly based on Mozilla 1.7.2. But unfortunately it seems to be using Mozilla's profile, so it may conflict with your Mozilla (but not Firefox and Thunderbird).

Related news in the blogosphere:


Note that troll and spam comments will be deleted without any notification.

Post a Comment

<< Home